• 462 بازدید
  • بدون نظر

معمولا هر قالب وردپرسی برای عملکرد صحیح نیازمند نصب و فعال بودن چندین افزونه ضروری می باشد این پلاگینها معمولا برای ایجاد امکاناتی مانند: سئو وردپرس ، نمایش آمار بازدید مطالب سایت، ایجاد امکان نمایش مطالب محبوب و … در بخشهای مختلف پوسته کاربر دارند. یکی از روشهای رایج برای اطلاع مدیر سایت جهت نصب افزونه های لازم، قرار دادن فایل راهنما به همراه پلاگین های ضروری در فایل قالب وردپرس می باشد که معمولا برای پوسته های تجاری از این شیوه استفاده می شود و در پوسته های رایگان فقط به ذکر نام افزونه های لازم اکتفا می شود در این مطلب از سایت قصد معرفی توابع و کدهای لازم جهت نمایش پیام هشدار فعال نبودن افزونه وردپرس مورد نیاز قالب جدید نصب شده به همراه فیلم آموزش فارسی ویرایش کدها را که یکی از تکنیکهای پیشرفته طراحی قالب وردپرس می باشد را داریم پس تا انتها همراه ما باشید.

 

WP-plugin

 

نمایش پیام خطا یا هشدار فعال نبودن افزونه وردپرس

اگر پوسته وردپرس خارجی نال نشده را از سایت اصلی آن خریداری کرده باشید معمولا با پیام هشداری بعد از نصب قالب بر روی هاست مواجه می شوید که از شما می خواهد برای عملکرد صحیح قالب و عدم ایجاد خطا افزونه های مورد نیاز لیست شده را نصب نمایید، نحوه نمایش پیام شرطی می باشد یعنی اگر افزونه ها را نصب و فعال داشته باشید خطایی نمایش داده نمی شود اما اگر غیرفعال یا نصب نشده باشند پیام هشدار نمایش داده می شود.

 

برای ایجاد این قابلیت ابتدا از فانکشن پوسته تان پشتیبان بگیرید سپس کدهای زیر را به ابتدای فایل فانکشن functions.php قالب وردپرسی که در حال طراحی آن هستید اضافه کنید. چون این قابلیت تنها در نصب اولیه پوسته مورد نیاز است نیازی به وجود ان در پوسته ای که به درستی کار می کند و مدتهاست نصب وفعال است، نیست. برای توضیح استفاده و ویرایش کدها جهت افزودن پلاگینهای بیشتر به لیست، فیلم آموزشی را مشاهده نمایید.

 

 

مطالب مرتبط
vpn خرید